Setting up Manticore on the Raspberry Pi 3 running Buster

Ray.Edgley's picture

Going  back some time ago, I created a tutorial here on setting up MRL on the Raspberry Pi.
Since then, the version of the Rasbian system has changed along with a lot of updates, and those instruction are now out of date.

Here is a link to a video starting with loading the OS onto a micro SD card and working your way through to getting Manticore running on the Raspberry pi 3.
 

So sit back and enjoy.

https://youtu.be/-uc9DxDoj9Y

 

Ray.

New InMoov Architecture - Embrace Your Pub/Sub !

GroG's picture
Internal References - Fragile Skeleton Pub/Sub - No Internal References

We Like Stop Buttons !

GroG's picture

Astro - sorry for the tragic end of your servo :(

I can tell you the sweep could not be stopped, now it can with build 191 and I've added a stop button which "should" stop the servo from any movement.


Music Recognition API

astro's picture

I don't know if this topic has already been discussed, maybe in the future music recognition can be added

https://audd.io/


MRL Raspberry PI 4 64 Bit

Merkstenix's picture

Hey, i am currently printing out the Inmoov Robot. I want to use a Raspberry PI 4- 4Gb as brain but i have some trouble setting up Myrobotlab at the PI. I already installed the 64bit Rasperry OS Image on a SSD, installed Java64Bit and Myrobotlab. My problem is, i can't set the Com Port for the (left) Arduino.

Servo Bug Hunt - Mop Up

GroG's picture

What's Left ?

  • if pr for previous fix is worky - ServoTest should be updated to lock it in place (disable => stop() & detachPin() )
  • no enable after attach  -  this may be correct in "general" but not for re-sync ???
  • TimerEncoder cleanup ?
  • setMaxVelocity / setMaxSpeed ?

Bug Hunt - #2 My Disabled Servo Made Wild Movements Next Move !

GroG's picture

 

I already fixed a bug Gael pointed out regarding autoDisable happening too soon in a long move. But, this bug flushed out another bug, I call it "Disable to Crazy Move".

It was easier to reproduce when the autoDisable bug was still causing problems, but you can reproduce it currently by doing the following.

1. Create a long move .. This can be done by :
2. Setup an Arduino & Servo
3. Set speed to 10
4. Start the servo at 0 move it to 180
5.  While the servo is moving - disable it.


Invert Bug

astro's picture

I found a bug in the invert, it deactivates itself by touching the input or output limits
 


Notification Plans ?

GroG's picture

Hi Astro.
I was wondering if there were plans for this Notifications area - and I guess I was trying to figure out if I incorrectly merged.   Yesterday we managed to merge webgui_work and meta branches into develop.  Which is 100s of changes from different people into the soup pot (develop).  I am wondering if I spilt some soup in the process ?